Googleのサイト証明書を取得してみる(2)

Googleのサイト証明書を取得してみる(1)の続きだよ。
今回も笑える結果が待っている。
さて、結果を先に書くと、証明書は取れました。

前回、extra/httpd-vhosts.confをインクルードするとApacheが落ちる件。
これは、記述方法が間違っていたのが理由だった。
全文記載しておく。
多分、ちょこちょこっと書き直すと、どこのサイトでも対応できそうなんだ。
おまけにAIさんの丁寧なコメント入りだよ。

当然だが、この記載内容はAIさんに全面的に依存している。
さて、これで立ち上がれば……をぉエラー吐かないぞ。普通にwww.k-in.co.jpの内容が見られた。
因みにhttpd.confに追加した
NameVirtualHosts *:80
NameVirtualHosts *:443
は、要らなかった、もうすぐ切り捨てられるんだそう。
何故ならApacheが賢くなって、等の中の、ServerName niwakan.k-in.co.jpを読んだら、Named Virtualだと解釈してくれるようになったかららしい。
多分、Apacheは自分より頭良いな。(羨ましい……

さあ、次です。
実際にSafariで見てみましょう。
niwakanなんて無いって帰ってくる。何故?

あぁ、内部DNSに追加するの忘れてた。
追加しました。
nslookupではきちんとipが出ます。

そっか、逆引きできないサイトって、逆引きが書けない(ローカル内部で動いている)のか、そうかこうなっているのか。
あれ違うかも、外に出た後では書けるな、その筈だ。単なる手抜き?どっちだ?

閑話休題。
SafariはmDNSResponder全面依存だろうから、Google Chromeで確認してみる。

立ち上がった。
index.htmlがたった一つ入っているだけだけど、見ることはできた。

pathも通ったことだし、これで証明書取得条件は整ったね。
AIさんに言われた通りに、コマンドを叩く。

あれ?Googleと関係ないよ。letsencrypt.orgってどういうことだろう?
LE-SA-v1.8-July-06-2026.pdfってGoogleとも共通な解説かなんかなのだろうか?
でもGoogleなら自前の用意しそうな物だけどなぁ。

上手く行ったみたい。

では試してみよう。

エラーになった。
AIさん曰く、「niwakan.k-in.co.jpの証明書の記述が無いから、Apacheがwww.k-in.co.jpの証明書を流用した」とのこと。
若しかしてhttpd.confの中に証明書ファイルの記述がないのか。
exstra/httpd-vhost.confに追加されるのだと思ったのだけどな。
とextraの中を覗くと新しいファイルが増えていた。

そっか、別ファイルになるんだね。
なので、httpd.confに、httpd-vhosts.confの後へ追加する。
そしてapachectl restart。
さてどうなりますことか。

結果。

無事に読み込めるようになりました。
当然、証明書を確認します。

さて、タイトルの「Googleのサイト証明書を取得してみる(2)」ですが、証明書はInternet Security Research Groupに発行して貰えました。
Googleコンソールの設定、何処へ行った?

コメントを残す

メールアドレスが公開されることはありません。 ※ が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)